Намиране на забравена парола на x86-базиран Mikrotik

Устройствата предлагани от Микротик са много гъвкави и удобни. В накой случай обаче е добре да се направи тестова постановка. Тогава е удобно да се ползват виртуални машини. Микротик като виртулна машина е много гъвкав, тъй като позволява да се дефинират голямо количество интерфейси и други хардуерни параметри.
По-долу е описан метод по който може да се възстанови забравена парола на Микротик x86, тъй като официалната страница твърди, че единствения начин е преинсталация на чисто (http://wiki.mikrotik.com/wiki/Manual:Reset).

За целта трябва да се извади от Микротик-а файла който съхранява паролите на потребителите. Ако имате архив, той също ще свърши работа и може да прескочите следващите стъпки.
Стъпките за извличане на файла с паролите са следните:
Монтирате ISO имидж на Ubuntu (или друга дистрибуция) към виртуалната машина на Микротик
Осигурявате необходимата RAM памет за нормална работа на дистрибуцията (поне 512МБ)
Стартирате от ISO-то и избирате Try Ubuntu без инсталация за да достигнете до графичната среда
След като се отвори File Explorer-а ще видите дяловете на Микротик (или чрез команда mount ръчно може да си ги монтирате)
Намирате директорията RW. Самият файл се казва USER.DAT се намира в /rw/store/user.dat
Копирате го на външна флашка или друг диск
Спирате Микротик-а и премахвате ISO имиджа – той вече не е нужен

На друга Линукс машина трябва да се инсталира инструмента с който ще се декриптира файла. Това става по следния начин:

sudo apt-get update
sudo apt-get install build-essential g++ libssl-dev libcurl4-gnutls-dev libexpat1-dev gettext libz-dev
mkdir ~/Desktop/temp
cd ~/Desktop/temp
wget http://manio.skyboo.net/mikrotik/mtpass-0.9.tar.bz2
tar jxvf mtpass-0.9.tar.bz2
cd mtpass-0.9
make
g++ -lssl -lcrypto mtpass.cpp -o mtpass

(Може да се компилира и по следния начин: g++ mtpass.cpp -lgnutls-openssl -o mtpass)

След това се пуска:

./mtpass user.dat

или

./mtpass mikrotik.backup

Резултата е следния:

mtpass5

Източник

https://aacable.wordpress.com/2012/01/14/howto-recover-mikrotik-admin-account-forgotten-password/
http://manio.skyboo.net/mikrotik/

Advertisements

Скрипт за динамично обновяване на DNS с помоща на No-IP за Mikrotik

Ако имате реален IP адрес който не е статичен и бихте желали да го достъпвате е най-лесно да си регистриране някоя от безплатните услуги от сорта на DynDNS или NoIP. За да работят те е необходим агент, който трябва да се инсталира и конфигурира на някое ПЦ (или рутер) в мрежата зад този адрес. Обикновенно при настройката се задава през какъв интервал този агент да се свързва към тези доствчици за осигуряване на динамични имена и да рапортува реалния външен адрес. Тук ще покажа един прост скрипт за Микротик който работи с NoIP и ви освобождава от нуждата да инсталирате агент на някакво ПЦ.

След като си направите регистрация в NoIP отивате във вашия Mikrotik и от System -> Scripts въвеждате следния скрипт:

##############Script Settings##################
 :local NOIPUser "име"
 :local NOIPPass "парола"
 :local WANInter "име на интерфейса за Интернет"
 :local NOIPDomain "твоятдомейн.no-ip.org"
 ###############################################
 :local IpCurrent [/ip address get [find interface=$WANInter] address];
 :for i from=( [:len $IpCurrent] - 1) to=0 do={
   :if ( [:pick $IpCurrent $i] = "/") do={
     :local NewIP [:pick $IpCurrent 0 $i];
     :if ([:resolve $NOIPDomain] != $NewIP) do={
        /tool fetch mode=http user=$NOIPUser password=$NOIPPass url="http://dynupdate.no-ip.com/nic/update\3Fhostname=$NOIPDomain&myip=$NewIP" keep-result=no
       :log info "NO-IP Update: $NOIPDomain - $NewIP"
      }
    }
 }

Като въвеждате вашите данни както е описано в скрипта по-горе. Отбелязвате read, write и test полиситата както е показано на картинката:

mikrotik-noip1

Може да изпълните скрипта с бутона “Run Script”, но за да го направите да се стартира автоматично трябва от System -> Scheduler да направите нова задача за изпълнение през определен период от време. Следния пример на картинката показва как би могла да изглежда такава задача:

mikrotik-noip2

Това което остава да направите е да осигурите рутера ви да позволява входящи връзки и да пренасочвате трафика по подходящ начин към вътрешната мрежа.

Повече информация има на този адрес: Dynamic DNS Update Script for No-IP DNS (http://wiki.mikrotik.com/wiki/Dynamic_DNS_Update_Script_for_No-IP_DNS)

Работа с VLAN-и и Realtek мрежови карти

VLAN-ите се ползват масово в съвременните мрежи за по-добра организация и логическо разпределение на връзките. Много често администраторите имат нужда от достъп по едно и също време до различни VLAN-и за да могат бързо да си изпълняват своята работата. За да се реализира това може се използват няколко различни мрежови карти на един компютър. Това разбира се не е много рационално, а дори и неудобно ако се ползва преносим компютър (с USB to LAN адаптери примерно).

Съвременните Intel-базирани мрежови карти разполагат с инструмент който позволява да се работи с различни VLAN-и при наличие на една мрежова свързаност. За съжаление, те не са толква често срещани при работни станции от нисък клас и евтини лаптопи, а вместо тях масово се ползват по-евтини Realtek-базирани решения. Но, оказва се, Realtek също имат инструмент, който може да инсталира виртуални мрежови карти, които да бъдат настроени за различни VLAN-и. Realtek Ethernet Diagnostic Utility е пакета който трябва да инсталирате за да може да се възползвате от тази функционалност. Актуалната версия може да намерите от сайта на производителя (тук) напълно безплатно. Налични са версии за Windows XP/7/8/10 на архива Windows Diagnostic Program който трябва да свалите.

След инсталация ще се появи ново меню в списъка с програми:

realtek_cfg0

При стартиране на инструмента ще видите раздел VLAN:

realtek_diag

При избиране ще видите опции за добавяне нов VLAN. Ако го направите и разгледате мрежовите карти налични в Windows ще забележите, че за всеки нов VLAN който създавате се появява нова виртуална мрежова карта. В нейните настройки може да изберете протоколите който желаете:

realtek_cfg3

Ако искате да промените вече устновен VLAN може да го направите или от инструмента на Realtek или от Advanced настройките както се вижда от тук:

realtek_vlan_cfg

Оригиналния, физически адаптер остава наличен, като в неговите настройки трябва да премахнете всички протоколи така, че да остане само Realtek Vlan Protocol Driver (NDIS 6.x):

realtek_cfg1

За да работи всичко нормално трябва опцията Priority & VLAN да е Enabled както се вижда:

realtek_cfg2

На този етап, ако вече сте си дефинирали някакви VLAN ID-та (и има налични такива конфигурирани от мрежовите администратори) мрежовите адаптери ще си вземат съответните настройки по DHCP (ако има такива в съответния сегмент) или ще трябва сами да си установите IP настройките. Имайте предвид, че в зависимост от реда на инициализиране на картите, настройките в Windows за пътя на рутиране (default gateway) могат да бъдат променени. Може да проверите това с route print командата и да установите подходящи metric настройки (за да не е Automatic):

realtek_cfg5(може и чрез netsh set interface “име на интерфейс” metric=xxx).

Сега, след като разполагате с много карти, можете да ги използвате за по-комфортна работа както намерите за добре.

Например, възможно е да установите виртуална машина (примерно VMware) да бъде свързана към съответната VLAN мрежа като използвате Virtual Network Editor-а:

vmware_realtek_cfg1

По този начин ако укажете на дадена виртуална машина да използва VMnet14, както е показано на картинката, тя ще има достъп до мрежата със съответния VLAN.

Успех и приятна работа!

Източници и допълнителни материали:

Realtek Software: Drivers & Utilities
http://www.realtek.com.tw/Downloads/downloadsView.aspx?Langid=1&PNid=13&PFid=5&Level=5&Conn=4&DownTypeID=3&GetDown=false

Fun with Vyatta and home routing
http://virtuallymikebrown.com/2013/01/08/fun-with-vyatta-and-home-routing/

Realtek Virtual LAN Drivers on Windows
http://todaystechonology.blogspot.bg/2012/10/realtek-virtual-lan-drivers-on-windows.html

Разрешаване на VNC достъп до виртуална машина на ESXi

VMware Workstation предлага възможност за достъп до виртуалните машини през VNC. Подобна функционалност е налична и на ESXi сървърите макар и да няма такава опция в менютата.
По-долу ще видите инструкции как да разрешите VNC функционалност на дадена виртуална машина при ESXi 6.

1. При изключена виртуална машина, от Edit -> Options -> Advance, General -> Configuration Parameters… използвайте бутона Add Row за да добавите следните елементи:

RemoteDisplay.vnc.enabled = TRUE
RemoteDisplay.vnc.port = порт (примерно 5900)
RemoteDisplay.vnc.password = парола

 

vmware-esx-vnc1

Портовете трябва да са различни за всяка една виртуална машина. Тези промени могат да се направят и директно във .vmx файла на виртуалната машина при изключено състояние.

2. Следва да се проверят услугите на ESXi хоста от Genereal -> Security Profile, Firewall -> Properties за да се уверим, че gdbserver-а е разрешен:

vmware-esx-firewall-gdbserver

3. Включвате виртуалната машина и чрез VNC клиент пробвате да се закачите като укажете порта който сте писали в конфигурацията. Пример:

vnc-esxi

Допълнителна информация и източници:

Configuring VMware ESXi virtual machine console – VNC

Using a VNC Client to Connect to VMs in ESXi 5

VNC client connect to esxi 6 console keeps drop

Откриване на забравена парола за Wi-Fi мрежа

Ако сте записали някаква WiFi мрежа за която сте се закачали преди време и искате да я споделите с някой друг, но не се сещате, какво ще направите? В този случай инсталацията на различни допълнителни проложения който ровят в Windows ще е напълно излишно защото може да видите всички пароли за секунди без да има нужда от специални програми.
Ето няколко команди с който можете да го направите.

Първо стартирайте cmd.exe като администратор. След това трябва да се видят всички профили за безжични мрежи който са записани в Windows:

netsh wlan show profiles

След като сте идентифицирали мрежата/профила за която искате да видите паролата, напишете:

netsh wlan show profiles name="име" key=clear

където “име” е името на профила който обиукновенно е SSID-а на мрежата.
Сега остава да погледнете реда който започва с “Key content” и … готово. Това е всичко!

Търсите още информация за безжичните мрежи?

Чрез следната команда може да получите детайлна информация за мрежите около вас:

netsh wlan show networks mode=bssid

wlans
Пълна информация за WLAN настройките може да получите по следния начин:

netsh wlan show all

В Windows 7/8/10 информация за wi-fi профилите се пази в:
C:\ProgramData\Microsoft\Wlansvc\Profiles\Interfaces\{GUID}
В Registry-то може да ровите в:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WlanSvc\Interfaces\{Interface Guid}\Profiles

Информация при WinXP може да се открие в Registry:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WZCSVC\Parameters\Interfaces\{Interface Guid}

Източници:
Revealing your WLAN password using netsh and PowerShell
Use PowerShell to Manage Auto-Connect Wireless Networks

Смяна на порта на който слуша RDP протокола

Remote Desktop Protocol

Remote Desktop протокола по подразбиране работи на порт 3389. Тази настройка може да бъде сменена през Registry. За Windows XP/Vista/7 това може да стане след промяна на следния ключ:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TerminalServer\WinStations\RDP-Tcp

Ключа който трябва да се промени е PortNumber.

Могат да бъдат задавани стойности от 1-65535 (1-ffff).

rdp_port

След промяна е необходим рестарт на компютъра.

Закачането от RDP клиента става като след името се поставят две точки и порта който сме избрали. Пример: 192.168.x.y:port

След подобна промяна следва да се провери firewall-a и да се създаде подходящо правило ако е необходимо.

Източник:

How to change the listening port for Remote Desktop

 

Филтриране на сайтове/домейни с помоща на Mikrotik firewall

Mikrotik са отлично решение за малкия и среден бизнес. Множеството им възможности предоставят гъвкаво управление и са подходящо решение за различни задачи.
Понякога се налага да бъде блокиран/филтриран даден сайт (или домейн) на Mikrotik рутера за да не могат да го достъпват потребителите зад него. Това може да се стане по описания по-долу начин.

Филтриране на домейн/сайт

Това става най-лесно с layer7-protocol който позволява претърсване по шаблон в ICMP/TCP/UDP потока.
За да се направи филтър е нужно следното:

  • От IP -> Firewall, се отваря раздела ‘Layer7 Protocols’
    Въвежда се името (или част от него) на домейна, както е показано в следния пример: ^.+(facebook.com|youtube.com).*$

mikrotik-firewall0

  • Тук се включват два сайта (facebook.com и youtube.com). Всеки следващ може да бъде добавен с разделител – `|`.

mikrotik-firewall1

  • Следва дефиниране на правило, което се настройва по следния начин:

mikrotik-firewall2

  • Указва се полето Layer7 Protocol:

mikrotik-firewall3

  • Задава се правило което да отхвърля пакетите:

mikrotik-firewall4

След като е конфигурирано правилото изглежда по следния начин:

mikrotik-firewall5

Допълнителна информация

Manual – IP/Firewall/Filter

Manual – IP/Firewall/L7

Firewall